Bug Tracker

Opened 8 years ago

Closed 8 years ago

#8677 closed bug (invalid)

Jquery 1.5.1 - Break on error - (b is undefined at line 16 - jquery.min.js)

Reported by: l.declercq@… Owned by: l.declercq@…
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hello ;

All is in the title. Error reported by firebug 1.5.4 during parsing.

Sorry in advance since I've not searched for duplicate bug entries.

Change History (2)

comment:1 Changed 8 years ago by dmethvin

Owner: set to l.declercq@…
Status: newpending

Please provide a test case in jsFiddle.

comment:2 Changed 8 years ago by addyosmani

Resolution: invalid
Status: pendingclosed

The issue you're experiencing is usually caused by older versions of Firebug being set to 'break on all errors'. From what I've read, support for handling errors being caught inside catch() (which is done in certain places across the jQuery codebase) was quite poor a few versions ago, but has since been improved. Please try using Firebug 1.7 or 1.8 alpha instead. As such, this isn't an issue with jQuery, but rather one with Firebug and as such we'll be closing it since there's not really much we can do about our try/catch usage. If you find the issues persisting, please report this bug on the Firebug bug tracker.

Note: See TracTickets for help on using tickets.