Bug Tracker

Opened 15 years ago

Closed 15 years ago

#863 closed bug (fixed)

click trigger works different in all but IE

Reported by: alex.lg Owned by:
Priority: major Milestone: 1.1.3
Component: event Version: 1.1
Keywords: diffence, IE6, FF Cc:
Blocked by: Blocking:

Description

[SVN Version 1159]

Running the Test-Suite in Firefox the Results are displayed as expected by the Test-Suite, finally displaying the result-page.

Running the same in IE6 opens the http://diveintomark.org/ page, which is caused by the first click(). called in the first test for .toggle()

(Line 9 of eventTest.js : link.click().toggle(fn1, fn2).click().click().click().click().click();

Change History (6)

comment:1 Changed 15 years ago by joern

Summary: Different results in eventTest between IE6.x and FF1.5xtoggle/click broken in IE

I modified the testsuite to at least stop moving to the mentioned site. But the problem still exists, and due to the inconsitency with FF, it must be considered a bug.

comment:2 Changed 15 years ago by john

Summary: toggle/click broken in IEtoggle/click broken in all but IE

It's actually the other way around - IE is the only browser that actually, correctly, triggers the click event on an anchor. We have to simulate the desired behavior in all other browsers.

comment:3 Changed 15 years ago by john

Summary: toggle/click broken in all but IEclick trigger works different in all but IE

comment:4 Changed 15 years ago by Gilles van d

This code works in IE7 and FFX 1.5.0.9, but not in IE6:

In IE6, i do get into the "function()" part, it does find the element, but does NOT trigger the click event. jQuery('ul.stap1Hulp > li > a').click(function() { jQuery('input[@name=' + this.id + ']').trigger('click'); });

comment:5 Changed 15 years ago by Gilles van d

p.s. the element which does not work is a submit button (input[@type=submit]). If i trigger the "click" event nothing happens in IE6. There are multiple buttons of thesame type, all with different names. Since i can't change the underlying script, i don't know how the server side handles things. My guess is that it looks at the name of the pressed button.

comment:6 Changed 15 years ago by brandon

need: Review
Resolution: fixed
Status: newclosed

Fixed in Rev. 1765.

Note: See TracTickets for help on using tickets.