Bug Tracker

Opened 9 years ago

Closed 7 years ago

#8625 closed bug (invalid)

$(window).height() within iframe

Reported by: juancaaltamirano@… Owned by: juancaaltamirano@…
Priority: high Milestone: 1.next
Component: dimensions Version: 1.4.1
Keywords: ie9 Cc:
Blocked by: Blocking:

Description

$(window).height() value in a window is diferent within a iframe with content that overflow iframe size, it happens only in ie9

Change History (10)

comment:1 Changed 9 years ago by dmethvin

Owner: set to juancaaltamirano@…
Status: newpending

Can you provide a test case in jsFiddle, and include a more complete description of the problem you've observed?

comment:2 Changed 9 years ago by juancaaltamirano@…

Status: pendingnew

Here are an example of the problem: http://files.factor.ec/demo/iframe_container.html

if you test it on google chrome it works ok, but at Internet Explorer 9 the box within iframe increase instead of decrease at resize event, it fail in Internet Explorer without compatibility view.

comment:3 Changed 9 years ago by john

Keywords: ie9 added

We're going to report this to the IE 9 team.

comment:4 Changed 9 years ago by dmethvin

Status: newopen

comment:5 Changed 9 years ago by john

Component: unfileddimensions
Priority: undecidedhigh

comment:6 Changed 8 years ago by rodrigo@…

I'm facing the same problem, Height reports total height and not only visible height for IE9. For FF,IE8 and others it's perfect.

comment:7 Changed 7 years ago by mikesherov

Can someone please provide a test case for this bug?

comment:8 Changed 7 years ago by mikesherov

I can not reproduce this bug. http://jsfiddle.net/57ytD/2/ http://jsfiddle.net/xs3fe/2/

Is it possible that Microsoft actually fixed this in an update to IE9? Unfortunately, the test case from the original bug report is now a 404, which is why we ask for jsfiddle links in the first place.

I'm inclined to resolve as worksforme as I am unable to demonstrate the problem as described with the fiddle provided.

dmethvin, others... thoughts?

comment:9 Changed 7 years ago by mikesherov

Status: openpending

juancaaltamirano@…, this may be a long shot, but could you kindly provide this test case again, 18 months later? We're unable to reproduce the original problem anymore.

I doubt we'll be able to do much of anything anyway, but it's worth a shot!

comment:10 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.