Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8611 closed bug (invalid)

AJAX BROKEN IN JQUERY 1.5.1 ON IE8

Reported by: Celero Owned by: Celero
Priority: undecided Milestone: 1.next
Component: ajax Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

I'm trying to consume a JAX-RS Webservice written in Java from Jquery. I succeeded when my jquery version was set to 1.4.3. But I need for another purpose to updgrade my jquery version (to 1.5.1). Since then, my call to the webservice fails.

I need to use IE for my application, so i only encountered that in IE. When i switched back to an older version of jquery, everything works fine...

Change History (3)

comment:1 Changed 9 years ago by addyosmani

Owner: set to Celero
Status: newpending

Thanks for submitting a ticket to the jQuery Bug Tracker. In order to assist you further, could you please also submit a reduced test case on http://jsFiddle.net that reproduces the issue you are experiencing?

Please also try testing using jQuery-GIT to see if the issue submitted persists.

comment:2 Changed 9 years ago by Rick Waldron

Component: unfiledajax

comment:3 Changed 9 years ago by addyosmani

Resolution: invalid
Status: pendingclosed

Please note that with jQuery 1.5, we introduced a major re-write of the ajax module which came with a number of rather large changes to how it works beneath the hood. It would appear that your JAX-RS service was making use of some of the older code, and may need to be updated to reflect how ajax works in the newer versions of jQuery core. Fundamentally, you should be able to use the same signatures but I strongly recommend reading up on http://api.jquery.com/jQuery.ajax/ to note what changes were made.

Because your ticket appears quite generic and you don't seem to have pinpointed what in ajax is breaking for you at the moment, it would be best if you could double check your code, go through the ajax docs and see if there are any minor changes you may need to make to it. You can always ask in the jQuery Forums for assistance with this if needed.

When/if you find that the ajax docs don't assist in helping you resolve this and you've managed to ascertain exactly whats breaking for you, please feel free to open up a new ticket with the reduced issue and a test case and we'll be happy to help further.

Note: See TracTickets for help on using tickets.