Skip to main content

Bug Tracker

Side navigation

#8594 closed bug (worksforme)

Opened March 22, 2011 09:02PM UTC

Closed March 30, 2011 05:30PM UTC

jquery-min throws an exception in FF

Reported by: Owned by:
Priority: undecided Milestone:
Component: unfiled Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

A small comet application using long polling with jquery.ajax

throws Fehler: uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXMLHttpRequest.getAllResponseHeaders]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: :: anonymous :: line 16" data: no]

when I reload the site - example at

Everything works well when I use the uncompressed version of jquery.

Attachments (0)
Change History (2)

Changed March 23, 2011 06:25PM UTC by addyosmani comment:1

owner: →
status: newpending

Thanks for submitting a ticket to the jQuery Bug Tracker. In order to assist you further, could you please also submit a reduced test case on that reproduces the issue you are experiencing? I haven't been able to personally replicate this as yet with the same error.

Please also try testing using jQuery-GIT to see if the issue submitted persists.

Changed March 30, 2011 05:30PM UTC by addyosmani comment:2

resolution: → worksforme
status: pendingclosed

Your current page at is using the latest version of jQuery (minified) and when I run this in FF, I'm not seeing any of the same exceptions. I've also tried including your jquery-1.5.min.js (just for the sake of thoroughness) in a test page and no exceptions were experienced there either. Both the uncompressed and minified versions should be behaving the exact same and I believe in this case they are. Please check your long polling ajax code to see if there are any bugs in there breaking your ajax calls.