Bug Tracker

Opened 7 years ago

Closed 7 years ago

#8575 closed bug (invalid)

Internet explorer 7 + 8 animate error

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: 1.next
Component: effects Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

In IE7 and IE8 i get the follwing error:

Message: Invalid argument. Line: 144 Char: 219 Code: 0 URI: http://www.rugbyunion.org.uk/javascript/jquery1.4.2.js

here is the url to the page: http://www.rugbyunion.org.uk/click_overlay/animate_error.php

Change History (4)

comment:1 Changed 7 years ago by dmethvin

Owner: set to anonymous
Status: newpending

Can you provide a test case that is reduced a bit more?

comment:2 Changed 7 years ago by Rick Waldron

Component: unfiledeffects

comment:3 Changed 7 years ago by addyosmani

The code provided has been reproduced here http://jsfiddle.net/addyosmani/YEQUu/show/ but we really need you to reduce this further. Ideally, strip out any of the app-specific logic down to the point where we can see exactly what is causing an error in your page.

comment:4 Changed 7 years ago by addyosmani

Resolution: invalid
Status: pendingclosed

This appears to be another one of the tickets our bot forgot to automatically close after 2 weeks of no-response. I've been looking through your code again and the reason you're running into issues is likely because dlgTop (which you're using as the value in conjunction with .animate()) may not be getting correctly computed or calculated in IE. Perhaps take another look at this part of your code. As you haven't been able to reduce your test case down to a point where we can further confirm whether there is in fact a jQuery core issue we'll be closing this ticket. Feel free to comment back with a test case we can use if you would like this further chased up.

Note: See TracTickets for help on using tickets.