Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8552 closed bug (duplicate)

width() en height() functions return element's percentage value minus %-sign when parent's display is 'none'

Reported by: lmeurs Owned by:
Priority: low Milestone: 1.next
Component: dimensions Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

On FireFox 3.6 and Chrome 10.0 the width()/height() functions return element's percentage value with the %-sign stripped off, when parent's display is 'none'.

Internet Explorer 8 returns null, Opera 10.6 returns the width of the parent's parent.

See: http://jsfiddle.net/vegh4/

Change History (2)

comment:1 Changed 9 years ago by Rick Waldron

Component: unfileddimensions
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Rick Waldron

Duplicate of #7928.

Note: See TracTickets for help on using tickets.