Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8537 closed bug (invalid)

jQuery-Induced WebKit Rendering Issue

Reported by: andrew.zich@… Owned by: andrew.zich@…
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

I discovered a peculiar bug arising from jQuery being present while attempting to add new CSS tags to a loaded page in WebKit (Safari/Chrome). The page linked below demonstrates one of these rendering issues.

Before the JavaScript load fires, the page is designed to be completely red. On load, it adds a new <style> tag to the head which should color the page green but isn't under these circumstances in WebKit. The page does not use jQuery for any of this, jQuery is merely included. Presumably, it should make no difference whether or not jQuery is present if it is not used.

Here is the page demonstrating the error: http://azich.org/temporary/render.html

Here is the same page with jQuery removed to demonstrate that it does work when jQuery is not present: http://azich.org/temporary/render_nojquery.html

(Minified jQuery 1.4.2 has been inlined in the first page.)

Change History (4)

comment:1 Changed 9 years ago by andrew.zich@…

To clarify, by page I mean this example page. My actual use case is far more elaborate but for these purposes I boiled it down to the heart of the issue.

comment:2 Changed 9 years ago by addyosmani

Owner: set to andrew.zich@…
Status: newpending

Thanks for submitting a ticket to the jQuery Bug Tracker. Could you kindly reproduce your test case on jsFiddle as per our guidelines?. I also notice that you're using jQuery 1.4.2 as opposed to the latest version (1.5.1). Please be sure to test using jQuery 1.5.1 and also jquery-edge/git (which can be selected from within jsFiddle).

comment:3 Changed 9 years ago by azich

I have created jsFiddles for both of these but neither of them appear to be working in any of the browsers I tested before with my own pages.

Here is the jsFiddle with jQuery 1.5.1: http://jsfiddle.net/uJW63/

Here is the jsFiddle without jQuery: http://jsfiddle.net/2CvUr/

comment:4 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.