Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8507 closed bug (duplicate)

#

Reported by: robertgayle@… Owned by:
Priority: blocker Milestone: 1.next
Component: selector Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

The form serialize() method throws an error when an input field's name attribute is 'name': ex:
<form id='crRunForm' method="PUT">
<input type="text" name="code"/>
<input type="text" name="name"/>
</form>

.....

function bldRequestXML(formId) {[[BR]]
var params ='''$("#"+formId).serialize()'''; <--throws error

....
This happens in (minified) version: 1.3.2, 1.4.2, and 1.5.1

Here is the stack trace from 1.5.1:

Uncaught Syntax error, unrecognized expression: #[object HTMLInputElement]
k.errorjquery-1.5.1.min.js:16
k.filterjquery-1.5.1.min.js:16
kjquery-1.5.1.min.js:16
c.querySelectorAll.kjquery-1.5.1.min.js:16
d.fn.extend.findjquery-1.5.1.min.js:16
d.d.fn.d.initjquery-1.5.1.min.js:16
d.djquery-1.5.1.min.js:16
bldRequestXMLtestPortal.jsp:250
doMMCServicetestPortal.jsp:180
doStartRuntestPortal.jsp:127
(anonymous function)testPortal.jsp:79

link to relevant html and javascript snippet: http://jsfiddle.net/M75uf/2/

Change History (2)

comment:1 Changed 9 years ago by Rick Waldron

Component: unfiledselector
Priority: undecidedblocker
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Rick Waldron

Duplicate of #7212.

Note: See TracTickets for help on using tickets.