Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8486 closed bug (invalid)

find not working on a select in 1.5.1

Reported by: Jason Stone <jstoneie@…> Owned by:
Priority: blocker Milestone: 1.next
Component: selector Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I have this piece of code -

x = $('#country_select').find('option[text=Ireland]');

which finds the option for Ireland in the select with id 'country_select'.

It works in v1.3 and in 1.4.1, however does not work in 1.5.1

Cheers Jason

Change History (3)

comment:1 Changed 9 years ago by Rick Waldron

Component: unfiledselector
Keywords: needsreview added
Priority: undecidedblocker
Status: newopen

Confirmed

1.4.2: http://jsfiddle.net/rwaldron/pjLKs/2/ 1.5.1: http://jsfiddle.net/rwaldron/pjLKs/1/

I added quotes to the attr value to make sure it was in compliance with the selector requirement.

comment:2 Changed 9 years ago by timmywil

We have :contains for this. Is it valid to check text as an attribute?

comment:3 Changed 9 years ago by dmethvin

Keywords: needsreview removed
Resolution: invalid
Status: openclosed

This is another property-vs-attribute conflict. The new behavior is correct and consistent, since there is no text *attribute* on the option element. Use the :contains() pseudo.

Note: See TracTickets for help on using tickets.