Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8483 closed bug (duplicate)

Using any wrapping function removes `<script type="bogus">` from hierarchy

Reported by: krof.drakula@… Owned by:
Priority: high Milestone: 1.next
Component: manipulation Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

When using jQuery Templates and wrapping an element containing those templates, jQuery's wrap* functions remove all instances of <script> nodes, regardless of type.

While I'm not sure if this is expected behaviour for unknown script types (at least from what I've read in other tickets regarding jQuery.clean), this is a use case that has worked very well when offering templatable widgets.

I've attached a simple case of the widget templating mechanism I use to create such widgets:

http://jsfiddle.net/krofdrakula/dw6RA/

The example fails to attach <p>Correctly replaced</p> to the body, since when .find('script') fires, there are no such elements available in the DOM anymore.

Change History (2)

comment:1 Changed 9 years ago by Rick Waldron

Component: unfiledmanipulation
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Rick Waldron

Duplicate of #6180.

Note: See TracTickets for help on using tickets.