Skip to main content

Bug Tracker

Side navigation

#8471 closed bug (fixed)

Opened March 08, 2011 04:05PM UTC

Closed March 30, 2011 07:28PM UTC

Last modified March 14, 2012 06:18PM UTC

Documentation for end() shouldn't use the word 'closure' in the literary sense

Reported by: Owned by: addyosmani
Priority: low Milestone:
Component: unfiled Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

When talking about using end() at the end of a chain of end() calls, the documentation states:

The last end() is unnecessary, as we are discarding the jQuery object immediately thereafter. However, when the code is written in this form, the end() provides visual symmetry and closure—making the program, at least to the eyes of some developers, more readable.

The word 'closure' is fairly loaded in JavaScript and jQuery in particular for its technical meaning, and it may confuse people to say that this use provides 'closure'.

Attachments (0)
Change History (2)

Changed March 08, 2011 09:26PM UTC by addyosmani comment:1

owner: → addyosmani
priority: undecidedlow
status: newassigned

I think the probability of the word 'closure' in this case being misinterpreted is fairly low given it's placement in the sentence, but we'll consider revising the language of the docs and update if needed.

Changed March 30, 2011 07:28PM UTC by addyosmani comment:2

resolution: → fixed
status: assignedclosed

We've updated this here: