Bug Tracker

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#8471 closed bug (fixed)

Documentation for end() shouldn't use the word 'closure' in the literary sense

Reported by: [email protected] Owned by: addyosmani
Priority: low Milestone: 1.next
Component: unfiled Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:


When talking about using end() at the end of a chain of end() calls, the documentation states:

The last end() is unnecessary, as we are discarding the jQuery object immediately thereafter. However, when the code is written in this form, the end() provides visual symmetry and closure—making the program, at least to the eyes of some developers, more readable.

The word 'closure' is fairly loaded in JavaScript and jQuery in particular for its technical meaning, and it may confuse people to say that this use provides 'closure'.

Change History (2)

comment:1 Changed 12 years ago by addyosmani

Owner: set to addyosmani
Priority: undecidedlow
Status: newassigned

I think the probability of the word 'closure' in this case being misinterpreted is fairly low given it's placement in the sentence, but we'll consider revising the language of the docs and update if needed.

comment:2 Changed 12 years ago by addyosmani

Resolution: fixed
Status: assignedclosed

We've updated this here: http://bugs.jquery.com/ticket/8471

Note: See TracTickets for help on using tickets.