Skip to main content

Bug Tracker

Side navigation

#8463 closed bug (duplicate)

Opened March 07, 2011 07:30PM UTC

Closed March 21, 2011 06:57PM UTC

Last modified March 14, 2012 06:20PM UTC

Ajax broken in jQuery 1.5.1 on Opera 11

Reported by: Owned by:
Priority: undecided Milestone:
Component: ajax Version: 1.5.1
Keywords: Cc: miketaylr, jaubourg
Blocked by: Blocking:

This is a bugreport that Ajax() in jQuery 1.5.1 stopped working on Opera 11. It worked perfectly in jQuery 1.4.4, but not after upgrading to jQuery 1.5.1.

The error-callback of the Ajax() function is called, and returns textStatus="error" and errorThrown="No transport".

The problem only occurs in Opera. The other browsers work perfectly.

To reproduce this problem:

1. Go to using the latest Opera version.

2. Click on play

3. Click start single player game.

4. Enter your name, and click login.

5. The game then "crashes" because the Ajax() function doesn't return a correct result.

Thanks in advance for helping with this problem! Other than this Opera bug, jQuery 1.5 has been really great to use with

Andreas R.

Attachments (0)
Change History (11)

Changed March 09, 2011 02:52PM UTC by rwaldron comment:1

component: unfiledajax
owner: →
status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, test against the jQuery 0 GIT version to ensure the issue still exists.

Changed March 11, 2011 06:10PM UTC by jaubourg comment:2

I find it strange it would work in IE seeing as the "No transport" error is typical of a cross-domain request made on a browser that doesn't support CORS (Opera AND IE). Even stranger, if it's a cross-domain request happening, then it shouldn't have worked with 1.4.x (with a different error though).

Like Rick said, a reduced test case would be nice.

Changed March 14, 2011 02:26AM UTC by comment:3

Can confirm that this is happening here too, reverting to jQuery 1.4.4 resolves the problem for now.

Changed March 14, 2011 01:23PM UTC by comment:4

i have same trouble with opera 11.01 and jquery 1.5.1 when i use the load function

Changed March 21, 2011 06:14PM UTC by addyosmani comment:5

cc: → miketaylr, jaubourg

CC'ing Mike Taylor (Opera) and Julian Aubourg (ajax rewrite) for additional comments on this issue.

Changed March 21, 2011 06:22PM UTC by miketaylr comment:6

Can I get a better description of what it means for the game to "crash"? Using Opera 11.10beta, I seem to be able to play the game--though I get errors in the Error Console like:

JavaScript -

Unknown thread

js_breakpad reports error: Network error: error





Changed March 21, 2011 06:51PM UTC by comment:7

status: pendingnew

After a lot of debugging, I have finally found the cause of this problem with jQuery and Opera. The problem was related to the fact that all Javascript in is compiled with Google Closure Compiler. If I excluded jQuery 1.5.1 from being compiled through Google Closure Compiler, and included jQuery separately, then the problem disappeared.

Therefore, this bug should probably be renamed to "jQuery 1.5.x doesn't work in Opera when compiled with Google Closure Compiler". I don't know the real cause of this problem, but it seems clear to me that jQuery 1.5 can't be compiled with Google Closure Compiler.

I have just released a new version of, where the problems have been fixed.

Changed March 21, 2011 06:53PM UTC by miketaylr comment:8

Interesting...jQuery is now using Uglify.js now rather than Closure Compiler. I wonder what breaks it O_O

Changed March 21, 2011 06:57PM UTC by ajpiano comment:9

resolution: → duplicate
status: newclosed

Changed March 21, 2011 06:57PM UTC by ajpiano comment:10

Duplicate of #7318.

Changed March 27, 2011 11:35AM UTC by comment:11

This actually turned out NOT to be related to #7318, but instead is an error with Opera's Javascript processing that was triggered by an optimization of Closure-Compiler.