Bug Tracker

Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8435 closed bug (duplicate)

.data() removes leading zeros from data-xxx attribute values

Reported by: anonymous Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

When storing data attribute values in the DOM and referencing them via .data(), any leading zeros are removed from the data attribute value.

http://jsfiddle.net/5Vy3u/2/

Change History (2)

comment:1 Changed 6 years ago by addyosmani

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 6 years ago by addyosmani

Duplicate of #7579.

Please follow the bug reporting guidlines and use jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

Modify Ticket

Change Properties
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.