Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#8414 closed bug (duplicate)

jQuery.show() locked css display - failed the media queries

Reported by: anonymous Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: git
Keywords: Cc:
Blocked by: Blocking:

Description

Test page

http://jsbin.com/ejuva3/4

To test it:

Expected Result

  1. Starting with browser window with width > 640
  2. Then resize the browser window to width < 640px
  3. You will see the layout of list(a b c) changed.

Reproduce the bug

  1. Reload the test page.
  2. Start with a large browser window with width >640 px
  3. Click hide all -> show all
  4. Then resize browser window width < 640 px
  5. you will see the list doesn't change its layout.

The problem .show() function is overriding display in style attribute, instead of removing display:none, which may fail the media query that need to change the css display after first call of .show()

Change History (2)

comment:1 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

The problem is caused when YOU override the default CSS display property of span tags.

comment:2 Changed 8 years ago by Rick Waldron

Duplicate of #8099.

Note: See TracTickets for help on using tickets.