Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#8410 closed bug (duplicate)

Selecting of checkboxes different under 1.4.4 and 1.5 or above

Reported by: LaySoft Owned by: LaySoft
Priority: low Milestone: 1.next
Component: selector Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have two checkboxes:

<input type="checkbox" id="x"/> <input type="checkbox" id="x:y"/>

under jQuery 1.4.4

$(':checkbox[id=x:]').attr('checked','checked');

and

$(':checkbox[id=x\:]').attr('checked','checked');

checks only second checkbox.

But under jQuery 1.5 and 1.5.1 checks both checkboxes.

Change History (8)

comment:1 Changed 5 years ago by addyosmani

#8411 is a duplicate of this ticket.

comment:2 Changed 5 years ago by addyosmani

  • Component changed from unfiled to selector
  • Owner set to LaySoft
  • Priority changed from undecided to low
  • Status changed from new to pending

I've created a test case based on what you've provided http://jsfiddle.net/addyosmani/28uJG/ which appears to be working fine using jQuery 1.5 and 1.5.1 in both Firefox and Chrome. 1.4.4 did have issues however we've since made additional patches to address this.

Could you confirm which browser you're attempting to test with?. If not, we may not be able to assist further and this ticket will be closed.

comment:3 Changed 5 years ago by LaySoft

  • Status changed from pending to new

Sorry i forgot the browser. But something wrong with the bug tracker posting mechanism, because stripped "" characters from my code. Now i created a test with jsFiddle: http://jsfiddle.net/jHgHD/ I tested it with FF 4.0b12, Chrome 9, Opera 11, IE9, and all of them produced the error.

comment:4 Changed 5 years ago by LaySoft

Sorry, stripped again :) The stripped character is caret-circumflex, ascii 94.

Version 2, edited 5 years ago by LaySoft (previous) (next) (diff)

comment:5 Changed 5 years ago by dmethvin

  • Resolution set to worksforme
  • Status changed from new to closed

This seems to be working fine with both 1.5.1 and edge; both check boxes are checked on FF 3.6 and IE8/9.

comment:6 Changed 5 years ago by rwaldron

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:7 Changed 5 years ago by rwaldron

  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:8 Changed 5 years ago by rwaldron

Duplicate of #8229.

Note: See TracTickets for help on using tickets.