Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#8400 closed bug (duplicate)

AJAX error with Firefox and jQuery 1.5.1

Reported by: mw@… Owned by:
Priority: low Milestone: 1.5.1
Component: ajax Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

I am sorry if this ticket is not specific enough, but here is the problem I am encountering with jQuery 1.5.1 and Firefox 3.6.13 (error does not appear if I revert to jQuery 1.5.0 or use Chrome):

[Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXMLHttpRequest.getAllResponseHeaders]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: https://ajax.googleapis.com/ajax/libs/jquery/1.5.1/jquery.min.js :: anonymous :: line 16" data: no]

Above text is the "errorThrown" parameter given to my Ajax error handler.

Unsure if this is in any way related to bug 8135, but that was the closest I found when searching before submitting this.

Firebug console is showing this as a failed request with no response, but when I visit the specific URL it attempted to load, there are no problems.

Change History (3)

comment:1 Changed 8 years ago by jitter

Component: unfiledajax
Milestone: 1.next1.5.1
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

As you didn't provide a test case which reproduces your issue, there isn't much that can be done here.

From the error message I guess it's indeed a duplicate of #8135. Did you check the links I gave in my comment on that ticket? The most likely cause is that your connection broke because of some connectivity problems.

Please report back if you can provide a test case which reproduces your issue but isn't related to the possible causes for #8135

comment:2 Changed 8 years ago by jitter

Duplicate of #8135.

comment:3 Changed 8 years ago by adkison.adrian@…

I am also having this same exact problem, (Firefox 3.6 / jQuery 1.5.1). My problem is intermittent and I am seeing it in the error logs. I cannot reproduce it. :( I'm sad

Note: See TracTickets for help on using tickets.