Bug Tracker

Opened 11 years ago

Closed 11 years ago

#8399 closed bug (invalid)

find(input:hidden) is not correct.

Reported by: [email protected] Owned by: [email protected]
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

i am using jq 1.4.4,

my page just this, <table id="tb"> <tr><td><input type="hidden" /><input type="text" /></td></tr> </table>

what i done, var newTr=$('#tbtr:first').clone(true); alert(newTr.find('input:hidden').length); it is supposed to be 1, but here is 2.

Change History (2)

comment:1 Changed 11 years ago by jitter

Owner: set to [email protected]
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further. Also make sure to read the link given below, in order to provide a most useful bug report.


How to report bugs

comment:2 Changed 11 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.