Bug Tracker

Opened 8 years ago

Closed 8 years ago

#8393 closed bug (invalid)

load function in queue has bug

Reported by: anonymous Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

i want hide my div first, then load a page in it and then show div by this code :

<div id="mydiv" onclick=" $('#mydiv').fadeTo('slow',0).delay(1000).load('test.php').fadeTo('slow',1);"

</div>

but browsers first load the page in my div and then fade it to 0 then fade it to 1.

Change History (2)

comment:1 Changed 8 years ago by ktsabolov

Calling methods in this way (in chain) executes them simultaneously. To achieve desired result you should use callbacks. Please take a look at http://jsfiddle.net/RCMn4/ to understand what is all about.

comment:2 Changed 8 years ago by dmethvin

Resolution: invalid
Status: newclosed

This is not a bug, please ask for help on forum.jquery.com.

Note: See TracTickets for help on using tickets.