Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8374 closed bug (duplicate)

When using .click() on an input a delegate gets fired before the input's checked has been updated

Reported by: greg.waxman@… Owned by:
Priority: low Milestone: 1.next
Component: event Version: git
Keywords: Cc:
Blocked by: Blocking:

Description

I ran across what I believe to be a bug that dates back all the way to 1.4.2 and still exists in the latest git. When I call $(input).click(), the delegate gets called as expected, but it happens before the input's checked value gets updated appropriately. This makes it a requirement to call $(input)[0].click() to get the proper order to occur and the delegates to work correctly should they need the checked value.

  1. jsFiddle is of the problem: http://jsfiddle.net/xm6vv/
  2. jsFiddle of how it should work: http://jsfiddle.net/GMZjB/

Change History (2)

comment:1 Changed 9 years ago by jitter

Component: unfiledevent
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by jitter

Duplicate of #3827.

Note: See TracTickets for help on using tickets.