Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8366 closed bug (invalid)

KeyError: 'captcha_redirect'

Reported by: anonymous Owned by: anonymous
Priority: low Milestone:
Component: web Version:
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'b07bd3f0c2d34957f49abe7a',
 'recaptcha_challenge_field': u'03AHJ_VusyWDvZ6HoI5EI_l87Hol-yQDbTlH1dOtCr_KIcacG9rkSCuxbdCRbX5T_F-S0FwuictZzYmQBNvbXwKcA5ucUImNjwY6OBZwRSbtROf0Axr6RDjgfUD39_DgmOnY4JXaTTgW3-nOXtHEIfKjOWCgsrBAykTw',
 'recaptcha_response_field': u'ddiza prosodic'}

User agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (2)

comment:1 Changed 9 years ago by jitter

Component: unfiledweb
Milestone: 1.next
Owner: set to anonymous
Priority: undecidedlow
Status: newpending
Version: 1.5

Can you provide additional information? You report doesn't contain any information on what you were doing and if this is reproducible.

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.