Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8357 closed bug (duplicate)

Something breaks in IE9 RC - getElementsByTagName?

Reported by: contact@… Owned by:
Priority: high Milestone: 1.5.1
Component: manipulation Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by ajpiano)

SCRIPT438: Object doesn't support property or method 'getElementsByTagName' 
jquery-1.5.js, line 5460 character 4

That's what happens when you try to use jQuery 1.5 with the plugin Fancybox in IE9 RC.

Note that jQuery 1.4.4 does not exhibit this problem.

I created two jsFiddle pages. They are exactly the same and consist of JUST the pasted Fancybox extension (1.3.4) and jQuery (1.5 or 1.4.4), and then a line that indicates success at the end. They both work in most browsers. But in IE9 RC, the jQuery 1.5 version causes an error.

Here are the pages:

http://ajh.us/fancy-1.4 http://ajh.us/fancy-1.5

Change History (3)

comment:1 Changed 9 years ago by ajpiano

Description: modified (diff)
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by ajpiano

Duplicate of #8052.

comment:3 Changed 9 years ago by jitter

Component: unfiledmanipulation
Milestone: 1.next1.5.1
Priority: undecidedhigh
Note: See TracTickets for help on using tickets.