Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8356 closed bug (duplicate)

data property is infinty with the value:

Reported by: Kirkov Owned by:
Priority: high Milestone: 1.next
Component: data Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

If a element has a data property with the value "89e665923683", jQuery returns "Infinity" instead of the real value.

Using standard javascript getAttribute works fine.

See testcase on JS Fiddle: http://jsfiddle.net/kirkov/MBEP2/

Change History (2)

comment:1 Changed 6 years ago by jitter

  • Component changed from unfiled to data
  • Priority changed from undecided to high
  • Resolution set to duplicate
  • Status changed from new to closed

This isn't a bug. As described in the .data() documentation for the HTML 5 data-* attributes, just use .attr() when you want the actual precise value. Check the ticket below for more information.

comment:2 Changed 6 years ago by jitter

Duplicate of #7579.

Note: See TracTickets for help on using tickets.