Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8354 closed bug (duplicate)

jquery-latest.min.js fails when run with IE 9.0.8080.16413

Reported by: raifordb@… Owned by:
Priority: low Milestone: 1.5.1
Component: manipulation Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

SCRIPT438: Object doesn't support property or method 'getElementsByTagName' jquery-latest.min.js, line 16 character 59007

Repro source: <!DOCTYPE html> <html> <head>

<script src="http://code.jquery.com/jquery-latest.min.js"></script> <script src="http://ajax.microsoft.com/ajax/jquery.templates/beta1/jquery.tmpl.min.js"></script>

</head> <body> <script id="movieTemplate" type="text/x-jquery-tmpl">

<li><b>${Name}</b> (${ReleaseYear})</li>

</script>

<ul id="movieList"></ul>

<script>

var movies = [ { Name: "The Red Violin", ReleaseYear: "1998" }, { Name: "Eyes Wide Shut", ReleaseYear: "1999" }, { Name: "The Inheritance", ReleaseYear: "1976" }

];

/* Render the template with the movies data and insert the rendered HTML under the "movieList" element */ $("#movieTemplate").tmpl(movies) .appendTo("#movieList");

</script>

</body> </html>

Change History (3)

comment:1 Changed 9 years ago by ajpiano

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by ajpiano

Duplicate of #8052.

comment:3 Changed 9 years ago by jitter

Component: unfiledmanipulation
Milestone: 1.next1.5.1
Priority: undecidedlow
Note: See TracTickets for help on using tickets.