Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#8345 closed bug (duplicate)

document width includes scrollbar in IE but not in FF

Reported by: albinohawk Owned by:
Priority: low Milestone: 1.next
Component: dimensions Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery 1.5. Tested in IE 8.0.7600.16385 and Firefox 3.6.13

If the document is longer than the viewport (i.e. a vertical scrollbar is shown) then there is inconsistent behaviour between IE and Firefox.

In Firefox getting the document width using jQuery(document).width() will get the value without the scrollbar (expected behaviour)

In IE however getting the document width will return the width plus scrollbar width.

A test case which uses an 100% width element to show the discrepency can be found at http://jsfiddle.net/qzbzG/1/

Change History (2)

comment:1 Changed 8 years ago by jitter

Component: unfileddimensions
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Please see my comment on the ticket mentioned below.

comment:2 Changed 8 years ago by jitter

Duplicate of #8048.

Note: See TracTickets for help on using tickets.