Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8330 closed bug (duplicate)

Can not force form to submit

Reported by: garrychilds@… Owned by:
Priority: high Milestone: 1.next
Component: event Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

When attempting to submit a form using the code below jQuery core throws an error "target[targetType] is not a function".

$("#accountSettings").submit();

accountSettings is the id of the form to submit, the form also has the same name.

The following is a snippet of the jQuery core code where the error is being reported.

try {
if ( target[ targetType ] ) {
// Make sure that we don't accidentally re-trigger the onFOO events
old = target[ "on" + targetType ];

if ( old ) {
target[ "on" + targetType ] = null;
}

jQuery.event.triggered = true;
target[ targetType ]();
}

// prevent IE from throwing an error for some elements with some event types, see #3533
} catch (triggerError) {}

if ( old ) {
target[ "on" + targetType ] = old;
} 

Change History (4)

comment:1 Changed 9 years ago by garrychilds@…

I have just discovered that jQuery does not submit the form if the submit button is named submit, perhaps this should be looked into or documented.

Hope this helps

comment:2 Changed 9 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by Rick Waldron

Duplicate of #1414.

comment:4 Changed 9 years ago by jitter

Component: unfiledevent
Priority: undecidedhigh
Note: See TracTickets for help on using tickets.