Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8326 closed bug (duplicate)

Camelize problem with jQuery.fn.data()

Reported by: calvein@… Owned by:
Priority: high Milestone: 1.next
Component: data Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I've made a fiddle to explain the problem. In fact, when you do $(el).data() you will get an object with the datas. If I have this : <el data-foo-bar="test">

$('el').data().fooBar will not work ($('el').data()foo-bar? will work) but in plain JS document.getElementsByTagName('el')[0].dataset.fooBar works.

http://jsfiddle.net/Calou/dJNES/

Change History (3)

comment:1 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by snover

Duplicate of #7328.

comment:3 Changed 9 years ago by jitter

Component: unfileddata
Priority: undecidedhigh
Note: See TracTickets for help on using tickets.