Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8325 closed bug (worksforme)

$("select"). [width/innerWidth/outerWidth] incorrect in Safari 5.0.3 Win

Reported by: kaneiderdaniel@… Owned by:
Priority: low Milestone: 1.next
Component: dimensions Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Use the following test case
http://jsfiddle.net/fUfeU/9/
to see the problem.

This test case just displays the width, innerWidth, and outherWidth of a simple visible select. My results:

  • Safari 5.0.3 Win: 8, 33, 33
  • Firefox 4.0b11: 32, 32, 36
  • Chrome 8.0.552 and 10.0.648: 31, 31, 33


As far as I understood, the .width should be somewhere around/between .innerWidth and .outherWidth.

Change History (2)

comment:1 Changed 9 years ago by snover

Resolution: worksforme
Status: newclosed

Thanks for the report, but this is not a jQuery bug. Different browsers/platforms apply different levels of browser chrome to form elements so they are not the same across platforms. Furthermore, I am not able to reproduce your Safari results; here, the testcase shows 38, 38, 38.

comment:2 Changed 9 years ago by jitter

Component: unfileddimensions
Priority: undecidedlow
Note: See TracTickets for help on using tickets.