Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8321 closed bug (invalid)

css() units returned

Reported by: Keigl Owned by: Keigl
Priority: low Milestone: 1.next
Component: css Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

I noted a few examples of the issue that is causing problems for me already posted in the css() page on the jQuery site, but it doesn't seem that anyone has submitted this as a bug.

So, I also would be interested in seeing the actual value of CSS elements returned by th css() function. Such was the case in the most recent version of jQuery that my team has been able to utilize (version 1.4.2) and prior versions. NOTE: 1.4.3 was not tested by our team, we had missed an upgrade, and so moved directly to 1.4.4 and have now tested with 1.5.

Here's the problem with 1.4.4 and 1.5. In versions of jQuery before and including 1.4.2, when a value was called, for example $("#divel").css("width"), if the unit contained in the stylesheet was other than "px" (perhaps "em") the "em" value would be returned. Ever since version 1.4.2 our team has been unable to upgrade to a newer version because many of our larger projects have been set up for "em", and now all that is being returned from such calls in new versions is "px" converted values. It would sure be nice to be able to use the newest advances within jQuery again.

Change History (4)

comment:1 Changed 8 years ago by jitter

Component: unfiledcss
Owner: set to Keigl
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further. Also make sure to read the link given below, in order to provide a most useful bug report.


How to report bugs

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 8 years ago by Keigl

Link to jsfiddle displaying this issue: http://jsfiddle.net/tcAqC/21/

comment:4 Changed 8 years ago by anonymous

I am curious to learn whether or not this ticket is in the process of being re-opened? The issue raised remains valid despite the initial lack of an example with the submission. Also to update the ticket, the problem remains as of version 1.6.1.

Note: See TracTickets for help on using tickets.