Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8319 closed bug (duplicate)

AJAX no longer working on Blackberry Widgets using 1.5

Reported by: sefigrossman@… Owned by: sefigrossman@…
Priority: low Milestone: 1.next
Component: ajax Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Perhaps I need to configure the new AJAX module a certain way, and I'm not sure if you officially support Blackberry Widgets, but I created a barebones test with just a GET and it does not fire the callback. I replaced the jQuery file with 1.4.4 and it works fine.

Change History (5)

comment:1 Changed 9 years ago by jitter

Component: unfiledajax
Owner: set to sefigrossman@…
Priority: undecidedlow
Status: newpending

Can you try setting jQuery.support.cors = true just after jQuery loaded and then report if the ajax calls work

comment:2 Changed 9 years ago by Sefi Grossman <sefigrossman@…>

jQuery.support.cors = true worked... is that the way it's going to be or is it going to be added to happen automatically in the next update?

comment:3 Changed 9 years ago by jaubourg

Yes, this is the way to handle this kind of scenario for unsupported environments. We don't have any mean to feature-test if the environment accepts cross-domain requests while not supporting cors... save from making a request at load time which is clearly not an acceptable approach.

comment:4 Changed 9 years ago by jitter

Resolution: duplicate
Status: pendingclosed

Closing, as the suggested solution works and is the correct way to handle environments which support cross-domain requests but not cors.

comment:5 Changed 9 years ago by jitter

Duplicate of #8122.

Note: See TracTickets for help on using tickets.