Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8309 closed bug (duplicate)

The selector with [value=Assign To] causes an exception

Reported by: jason.jong@… Owned by:
Priority: low Milestone: 1.next
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Code

   $("div.messageControlBar > input[value=Assign To]").live("click", AssignToShow);

Exception throw is Uncaught Syntax error, unrecognized expression: [value=Assign To] at line 3583.

It doesnt seem to allow the [value=Assign To] however it worked with previous versions of jQuery.

Change History (3)

comment:1 Changed 9 years ago by anonymous

Created a item in jsFiddle where you can see v1.4.4 works changing the button to red, but in v1.5, it doesn't

URL @ http://jsfiddle.net/2rUqP/

comment:2 Changed 9 years ago by jitter

Component: unfiledselector
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

This isn't a bug. Your selector isn't and never was valid, if this worked in earlier jQuery version it was actually a bug that got fixed.

Check this test case which shows that your selector isn't a valid CSS selector and that you need to enclose the attribute value in quotes. So that I don't need to repeat my self also check this comment

comment:3 Changed 9 years ago by jitter

Duplicate of #8229.

Note: See TracTickets for help on using tickets.