Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8300 closed bug (invalid)

Firefox/Opera JSONP call causes browser to "spin"

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.next
Component: ajax Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

When using a JSONP call, FireFox displays "Waiting for..." in the browser status and Opera just keeps spinning. This is especially annoying if you're using a long-polling JSONP call, but even with a regular polling call it keeps flickering.

Change History (3)

comment:1 Changed 9 years ago by jitter

Component: unfiledajax
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further. Also make sure to read the link given below, in order to provide a most useful bug report.


How to report bugs

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 9 years ago by zhuzii2001@…

Me too in FF3. example, first ajax sent to server.(call it ajax1, server will return after 50secs), then another jsonp ajax sent(call it ajax2), I found ajax2 response status 200 in firebug and exists correct response, but the script not execute in ajax2 success until ajax1 response.

well, I use dataType "json" in ajax2 will work ok.

Note: See TracTickets for help on using tickets.