Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8287 closed bug (invalid)

Elminate memory leaks reported by IEJSLeaksDetector.exe

Reported by: ss@… Owned by: ss@…
Priority: undecided Milestone: 1.next
Component: core Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by jitter)

The IE leak detector identifies two areas where JQuery apparently fails to remove onload/onunload handlers:

in the bindReady function, replaced window.attachEvent("onload" jQuery.ready) with:

window.attachEvent( "onload", function() {
    window.detachEvent("onload", arguments.callee);
    jQuery.ready();
});

in the // Prevent memory leaks in IE section, before the onunload function close added:

window.detachEvent('onunload', arguments.callee);
window.$ = null;
window.jQuery = null;

Change History (2)

comment:1 Changed 9 years ago by jitter

Component: unfiledcore
Description: modified (diff)
Owner: set to ss@…
Status: newpending

I tried a simple page with the exe found here . Didn't show any leaks for me with 1.5 .

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further. Also make sure to read the link given below, in order to provide a most useful bug report.


How to report bugs

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.