Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8286 closed bug (duplicate)

An element triggers a mouseout or mouseleave event when hovering over a child input text field contained within the element

Reported by: mx9.8080@… Owned by:
Priority: high Milestone: 1.5.1
Component: event Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

This bug is in Chrome only.

I have a div that contains an input text field. By default, the div is hidden and is shown on a button click event and hides on a mouseleave event.

In Chrome, if you hover over the containing text field, the mouseout/mouseleave event gets triggered and the div hides.

Use the following link to reproduce: http://jsfiddle.net/2AKAp/3/

Steps for reproducing:

  • Open up http://jsfiddle.net/2AKAp/3/ in Chrome
  • Click on button to show the div
  • Hover over anywhere in the div outside the text field and it should not hide
  • Hover over the text field and the div hides

Change History (3)

comment:1 Changed 9 years ago by anonymous

I have tried both mouseout and mouseleave events but no dice. I tried attaching them to live handler as well but same results.

comment:2 Changed 9 years ago by jitter

Component: unfiledevent
Milestone: 1.next1.5.1
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by jitter

Duplicate of #8209.

Note: See TracTickets for help on using tickets.