Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8282 closed bug (duplicate)

Attribute Selectors Without Quotes Stopped Working

Reported by: stephen@… Owned by:
Priority: low Milestone: 1.next
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

I recently upgraded an app from jQuery 1.4.2 to jQuery 1.5.0. I was using a query like the following:

$('[name=some[field]]')

This stopped working with a syntax error when I used 1.5. I was able to get the query to work with:

$('[name="some[field]"]')

Both queries work in 1.4.2, but the top one fails in 1.4.4 and 1.5.

Change History (3)

comment:1 Changed 9 years ago by anonymous

1.4.2 Test: http://jsfiddle.net/UeMcq/

1.4.4 Test: http://jsfiddle.net/EZ96m/

1.5.0 Test: http://jsfiddle.net/xty4s/

All tests done in Google Chrome 9.0.597.98.

comment:2 Changed 9 years ago by jitter

Component: unfiledselector
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by jitter

Duplicate of #8229.

Note: See TracTickets for help on using tickets.