Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8280 closed bug (invalid)

The class can not be set as "submit" with one() function

Reported by: Edison Chuang <millionbonus@…> Owned by:
Priority: low Milestone: 1.next
Component: event Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

An input element which in a form element. The class attribute of input element can not be set as "submit" with one() function or it will cause an error "types.split is not a function".

check out the link below (please open firebug): http://jsfiddle.net/jhND4/

Change History (3)

comment:1 in reply to:  description Changed 9 years ago by Edison Chuang <millionbonus@…>

check out the link below (please open firebug): http://jsfiddle.net/jhND4/1

comment:2 Changed 9 years ago by Edison Chuang <millionbonus@…>

An input element which in a form element. The class attribute of input element can not be set as "submit" with one() function or it will cause an error "types.split is not a function".

check out the link below (please open firebug): http://jsfiddle.net/jhND4/1

comment:3 Changed 9 years ago by jitter

Component: unfiledevent
Priority: undecidedlow
Resolution: invalid
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a test case!

After checking your report and the test cases I come to the conclusion that your report is invalid. The error you see is caused by your incorrect usage of the .one() method.

Please read http://api.jquery.com/one and check the method signature.

Note: See TracTickets for help on using tickets.