Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8276 closed bug (duplicate)

FireFox 3.6.13 Selecting Form Checkboxes checked items

Reported by: s.hamed.afghan@… Owned by:
Priority: low Milestone: 1.next
Component: css Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

in firefox it doesn't work

$("form :checked").css("border", "1px solid red");

Change History (4)

comment:1 Changed 9 years ago by addyosmani

Resolution: worksforme
Status: newclosed

Thanks for submitting a ticket to the jQuery Bug Tracker!.

As per our API documentation on :checked, this selector only works correctly for checkbox and radio elements. In your example you're trying to directly use :checked on a form which isn't supported. The correct way to use this would be selecting the input elements by doing something like $('form input:checked'). I've created a minimal fiddle example to demonstrate correct usage here (which does work fine in both latest Chrome and Firefox 3.6.13) Live Test Case.

comment:2 Changed 9 years ago by jitter

Component: unfiledcss
Priority: undecidedlow
Resolution: worksforme
Status: closedreopened

comment:3 Changed 9 years ago by jitter

Resolution: duplicate
Status: reopenedclosed

comment:4 Changed 9 years ago by jitter

Duplicate of #8278.

Note: See TracTickets for help on using tickets.