Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8268 closed bug (invalid)

jquery fade-show fails in IE

Reported by: niek Owned by: niek
Priority: low Milestone: 1.next
Component: effects Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Situation:

  • "Overlay div", 100% width/height. Positioned absolute.
  • Background color = #000
  • Opactiy is set (using filter for IE)
  • div is hidden (display: none)

In that situation, try to run a $("#overlay").show("fade", "fast");

This fails in Internet Explorer 7. The screen stays completely black. When I remove the effect, so only using .show("fade"), the opactiy does work.

IE version: 7.0.5730.11

Change History (3)

comment:1 Changed 9 years ago by jitter

Component: unfiledeffects
Owner: set to niek
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further. Also make sure to read the link given below, in order to provide a most useful bug report.


How to report bugs

comment:2 Changed 9 years ago by anonymous

The problem only occurs in IE7, because that's the only IE browser I tested on. It works as expected in Firefox 3.

http://jsfiddle.net/nFzdh/4/ is a simple test case. When visiting that link in IE, you can see the fade animation going well. But when the animation is finished, the complete #fade will turn completely black.

comment:3 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.