Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8258 closed bug (invalid)

[Regression] 1.5 selector throws error when attribute contains a dot "."

Reported by: Rich Hong <hong.rich@…> Owned by:
Priority: low Milestone: 1.next
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

This simple example shows that it used to work in 1.4.4 but now throws an error in 1.5

Example with jQuery 1.4.4: http://jsfiddle.net/uuehg/

Example with jQuery 1.5: http://jsfiddle.net/VpkMz/

Change History (3)

comment:1 Changed 9 years ago by snover

Resolution: invalid
Status: newclosed

Thanks for the report, but this is not a jQuery bug. Please read the API documentation on attribute selectors.

Last edited 9 years ago by snover (previous) (diff)

comment:2 in reply to:  1 Changed 9 years ago by hongrich

Replying to snover:

Thanks for the report, but this is not a jQuery bug. Please read the API documentation on attribute selectors.

Thanks. I see now that "Quotes are mandatory." And it works if I put the quotes around attribute. It would be nice if these sort of things are mentioned in the release note. Since the behavior changed from 1.4.4 to 1.5

comment:3 Changed 9 years ago by jitter

Component: unfiledselector
Priority: undecidedlow
Note: See TracTickets for help on using tickets.