Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8255 closed bug (fixed)

support for list attribute

Reported by: trixta@… Owned by:
Priority: low Milestone: 1.6
Component: attributes Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

list IDL attribute is supposed to be readonly. If an author wants to change the list attribute. He has to modify the content attribute.

I have created a demo: http://jsfiddle.net/trixta/D7YFx/

The attribute can't be changed in Safari 5.0.3 or FF4beta10.

I have also created a patch/pullrequest, wich adds the list attribute to the special treated attributes, like src/href (getAttribute('list', 2) doesn't hurt in ie).

You find the pullrequest @https://github.com/jquery/jquery/pull/213

And a discussion @ http://forum.jquery.com/topic/support-for-list-attribute-small-patch (currently not that usefull :-) ).

Change History (5)

comment:1 Changed 6 years ago by jitter

  • Component changed from unfiled to attributes
  • Priority changed from undecided to low

comment:2 Changed 6 years ago by jitter

  • Keywords needsreview added

comment:3 Changed 6 years ago by timmywil

updated pull request

comment:4 Changed 6 years ago by timmywil

  • Keywords needsreview removed
  • Milestone changed from 1.next to 1.6
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from 1.5 to 1.5.2

comment:5 Changed 6 years ago by timmywil

#8916 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.