Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8249 closed bug (duplicate)

$.getScript Fails Locally in 1.5

Reported by: [email protected] Owned by:
Priority: low Milestone: 1.next
Component: ajax Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

$.getScript() seems to not be executing the script or any callback methods in 1.5. When jQuery is replaced with 1.4.4 all works as expected.

The new jqXHR Object is created and does include the responseText property set with the string representation of the requested JS file but no optional return methods are fired and the response text is not executed.

Bug was reproduced in Firefox 3.6.13 on Windows 7.

Steps to reproduce: On page load, run:

$.getScript('aScript.js');

Creating a signifier in 'aScript.js' such as an alert dialog will show in jQuery 1.4.4 but not in jQuery 1.5

Change History (2)

comment:1 Changed 11 years ago by jitter

Component: unfiledajax
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 11 years ago by jitter

Duplicate of #8166.

Note: See TracTickets for help on using tickets.