Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8236 closed bug (duplicate)

live doesn't work with :not(:last)

Reported by: SLaks Owned by:
Priority: high Milestone: 1.next
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Writing $('div button:not(:last)').live(...) will catch events on all matching elements, even the (excluded) last one, and all of their parent elements.

Removing the div from the selector will cause live to not handle anything at all.

Changing live to bind will cause it to handle the correct elements, with or without div.

Using :not(.Class) or :last alone will work correctly even with live.

Tested on 1.5 and 1.4.4

http://jsfiddle.net/SLaks/aPnYv/

Change History (2)

comment:1 Changed 11 years ago by jitter

Component: unfiledselector
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 11 years ago by jitter

Duplicate of #5414.

Note: See TracTickets for help on using tickets.