Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8231 closed bug (duplicate)

.attr can't change a submit input

Reported by: remysharp Owned by:
Priority: low Milestone: 1.next
Component: attributes Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Changing a submit input element to a button (or perhaps another type) causes jQuery to throw a fatal exception:

$('input[type=submit]').attr('type', 'button'); throws fatal

Working example: http://jsbin.com/arida/2

Note that it throws an exception (which is why I've wrapped them in a try/catch for the example).

Change History (2)

comment:1 Changed 9 years ago by jitter

Component: unfiledattributes
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by jitter

Duplicate of #8232.

Note: See TracTickets for help on using tickets.