Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8230 closed bug (wontfix)

.each meses up html code in IE 6,7, FF 3.0.6

Reported by: sandiskr@… Owned by:
Priority: low Milestone: 1.next
Component: core Version: 1.5
Keywords: needsreview Cc:
Blocked by: Blocking:

Description

Repeated here: http://jsfiddle.net/mh3US/

Problem: <input> tag is switched with <select> box.

Description: .each is messing up the html code in specific browsers, like IE 6, 7 and FireFox 3.0.6. it is happening only when with specific code from other library, that is not affecting anything in newer browsers. Happens in 1.4.x and 1.5.

Change History (1)

comment:1 Changed 9 years ago by jitter

Component: unfiledcore
Keywords: needsreview added
Priority: undecidedlow
Resolution: wontfix
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a test case!

The problem is that your code overwrites the already present function on jQuery.fn.sort. As jQuery.fn.sort is used internally for some browsers this causes your function to be called instead of the original one.

The solution would be to not overwrite jQuery.fn.sort and instead name your proprietary function something else.

Note: See TracTickets for help on using tickets.