Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8228 closed bug (invalid)

Click events firing on wrong elements and animate problems

Reported by: brandnewdejavu Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Clicking on resume my fire portfolio, etc. Sometimes fires correctly. Sometimes not.

Animate with width = 50%, height = 50% goes to 100% when stops, plus doesn't look too pretty with this code.

Animate with left = - val sometimes goes to the right place. Sometimes not.

Also, would like to have event.target.name so that I know the name of the element the event fired on to clean up my code.

Will place code at http://www.sovsites.com tomorrow.

Change History (4)

comment:1 Changed 10 years ago by brandnewdejavu

animate doing something in IE.

click always firing on the about element rather than the one the event handler is assigned to.

Version 0, edited 10 years ago by brandnewdejavu (next)

comment:2 Changed 10 years ago by brandnewdejavu

Click on the tabs.

comment:3 Changed 10 years ago by addyosmani

Resolution: invalid
Status: newclosed

Thanks for submitting a ticket to the jQuery Bug Tracker. Unfortunately we're unable to help debug or fix complete projects as this can take a lot of time. The tracker is only for reduced issues with jQuery core that can be easily reproduced.

If you would like further assistance with your site, feel re-ask your questions in the jQuery Forums or on our freenode IRC channel #jquery as they would be able to assist further.

If you can reduce the cause of the problem down to something specific, feel free to re-submit your ticket and we'll be happy to re-evaluate at that point.

comment:4 Changed 10 years ago by anonymous

I just thought I'd quickly whip up what probably wasn't the best idea and see how it looks.

But, the whole thing is a mess. It's not holding or animating to my parameters.

I was double checking the shifting of the tab to the right, but it animates to a different location.

It also doesn't hold the 50%. And the 50% seems to simply truncate the div.

Note: See TracTickets for help on using tickets.