Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8222 closed bug (wontfix)

Double Asset Request for Video Tag

Reported by: ben@… Owned by: ben@…
Priority: low Milestone: 1.next
Component: manipulation Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

I've only tested this in Chrome 9, but here are the steps to reproduce:

  1. create an empty HTML document, embedding jQuery (I've tried this with 1.4.3 and 1.5
  1. create a video tag string, wrap it with jQuery (ex: var vidtag = $('<video controls="true"><source src="myvideo.mp4"></video>');)
  1. open the networking tools to see the files that chrome is requesting. myvideo.mp4 is requested twice.

Chrome is already relatively unstable when it comes to HTTPStreaming, this seems to be the straw that broke the camel's back. Doing a double request like this seems to lock up Chrome more often than not for me in my situation.

This problem seems unique to jQuery - setting the innerHTML of a div to the video tag without jQuery doesn't perform a double request, and of course neither does just having a video tag already on the page

Change History (4)

comment:1 Changed 9 years ago by jitter

Owner: set to ben@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further. Also make sure to read the link given below, in order to provide a most useful bug report.


How to report bugs

comment:2 Changed 9 years ago by anonymous

JSFiddle (hope I did this right, I've never used it) http://jsfiddle.net/NYNCF/2/

comment:3 Changed 9 years ago by Rick Waldron

Component: unfiledmanipulation
Priority: undecidedlow
Resolution: wontfix
Status: pendingclosed

comment:4 Changed 9 years ago by anonymous

Thanks very much - that worked great. I'm newish to jQuery, so if that's the correct usage to instantiate a tag like this, awesome.

Unfortunately, the code instantiation code isn't mine, but is from the HTML5 branch of the Open Video Player project.

I'll see if I can make a similar bug report to them.

Note: See TracTickets for help on using tickets.