Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8199 closed bug (invalid)

Including jQuery breaks Indico

Reported by: gundlach.business@… Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Repro:

  1. Visit http://cheops.php-4.info/~adrian/indico-jquery/materialsShow-no-jquery.html in Google Chrome.
  2. Click "Add Material".
  3. Notice that a popup window appears.
  1. Visit http://cheops.php-4.info/~adrian/indico-jquery/materialsShow.html in a new tab in Google Chrome.
  2. Click "Add Material".
  3. Notice that no popup window appears.

The only difference between the two links is that the latter has the line: <script src="http://code.jquery.com/jquery-1.5.js">

This test case is a copy of an internal page at CERN (that is breaking for Chrome users who have the AdBlock extension) -- so fixing this will make the Large Hadron Collider work better! :)

Change History (4)

comment:1 Changed 9 years ago by snover

Resolution: invalid
Status: newclosed

Thanks for the report, but this is not a jQuery bug. You have written invalid markup. You must close script tags.

comment:2 Changed 9 years ago by adrian.moennich@…

I've just closed the script tag in the testcase. The missing closing tag was NOT the reason for the issue (I simply forgot it when adding the jquery script tag to the testcase).

comment:3 in reply to:  2 Changed 9 years ago by jitter

Replying to adrian.moennich@…:

I've just closed the script tag in the testcase. The missing closing tag was NOT the reason for the issue (I simply forgot it when adding the jquery script tag to the testcase).

We would love to investigate this issue further, but with the "test-page" links you provided it's near to impossible to find out what might be cause for the problems you have. They both include lots and lots of javascript code in paritally minified/compressed form.

If you can provide a minimal test case, reproducing the problem and showing this is indeed a bug in jQuery, following the procedure in: How to report bugs we might be able to help you.


P.S. What I noticed is that the pop up seems to be there - on the jQuery included page - after clicking the link but for some reason isn't visible.

Executing $("div.exclusivePopup").css("position", "absolute") after clicking the link (e.g. in the url field or js-console) for some reason makes the pop up visible in Chrome.

comment:4 Changed 9 years ago by anonymous

Apparently this line of jQuery causes the bug to occur:

body.removeChild( div ).style.display = "none";
Note: See TracTickets for help on using tickets.