Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#8173 closed bug (invalid)

1.5 Ajax not triggering error for bad URL

Reported by: rdibona@… Owned by: rdibona@…
Priority: low Milestone: 1.next
Component: ajax Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by jitter)

This simple AJAX call includes a URL that doesn't exist. In 1.5 in Firefox it does not display the alert meaning the error is not being caught (or causes a runtime error in Firebug). In 1.4.4 it properly catches the error in the textStatus.

$('#cmdDetails').bind('click', function()
{
    $.ajax
    ({
        type: "GET",
        dataType: "json",
        url: "server/fakeurl.php",
        complete : function(data, textStatus, jqXHR)
        {
            alert(textStatus);
        }
    })
});

Change History (8)

comment:1 Changed 8 years ago by jitter

Component: unfiledajax
Description: modified (diff)
Owner: set to rdibona@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report!

After checking your report I made this live test case based on your description. I can't seem to reproduce the behavior you described, as I get an alert saying "error" in FF.

So please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further. Also make sure to read the link given below, in order to provide a most useful bug report.


How to report bugs

comment:2 Changed 8 years ago by addyosmani

If you could also include what version of Firefox you're testing with that would be of benefit.

comment:3 Changed 8 years ago by rdibona@…

Status: pendingnew

It had to do with making the AJAX call from within a form's submit button click event. For some reason, FireFox 3.6.13 did not like this. But it doesn't really have to do with the AJAX call itself, so you can close this ticket.

Thanks very much and I apologize that I did not enter the bug using the proper protocol.

comment:4 Changed 8 years ago by jaubourg

Resolution: invalid
Status: newclosed

comment:5 Changed 8 years ago by anonymous

Sorry, I dont like to create jsFiddle acc just to say how to reproduce the bug. Change URL.

url: "http://google.com/fakeurl.php?jsonpCallback=?"

JSONP does not trigger error callbacks, neither local nor global. In 1.5, 1.4.4, 1.4.3, 1.4.2.

comment:6 in reply to:  5 Changed 8 years ago by jitter

Replying to anonymous:

Sorry, I dont like to create jsFiddle acc just to say how to reproduce the bug. Change URL.

url: "http://google.com/fakeurl.php?jsonpCallback=?"

JSONP does not trigger error callbacks, neither local nor global. In 1.5, 1.4.4, 1.4.3, 1.4.2.

Because I can't reliably do so. And the documentation clearly states this behavior. http://api.jquery.com/jQuery.ajax

error: This handler is not called for cross-domain script and JSONP requests.

comment:7 Changed 6 years ago by lokitek@…

Just wanted to bring this bug back up to life, as it seems that using HTTPS in the connection prevents the error from showing up.

See Live Example

comment:8 Changed 6 years ago by dmethvin

Please *don't* jump on two-year-old closed bug threads, instead ask for help on the forum.

Note: See TracTickets for help on using tickets.