Bug Tracker

Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#8158 closed bug (duplicate)

Animating bottom to 0% fails on elements with a specified width in IE

Reported by: scottgonzalez Owned by:
Priority: high Milestone: 1.8
Component: effects Version: 1.5
Keywords: opera, ie7, ie8 Cc:
Blocked by: Blocking:

Change History (7)

comment:1 Changed 11 years ago by miketaylr

Keywords: opera added

<jitter> in doesn't work in opera too 10:34AM

If you set duration to e.g. 5000 you can see how #inner disappears. But if you trigger a reflow/redraw (e.g. alert(1) in the callback) you will see that opera actually does move the element to border:0% but you can't see that because Opera doesn't redraw. An interesting "workaround" for Opera is adding a e.g. <button> element below the #outer div.

The issue could be related but must not be. As in IE you get an exception at some point

Last edited 11 years ago by jitter (previous) (diff)

comment:2 Changed 11 years ago by jitter

Component: unfiledeffects
Priority: undecidedhigh

comment:3 Changed 11 years ago by jitter

Status: newopen

comment:4 Changed 10 years ago by scottgonzalez

This is likely the cause of http://bugs.jqueryui.com/ticket/7944 as well.

comment:5 Changed 9 years ago by mikesherov

not seeing this bug anymore in Opera. scott.gonzalez, can you confirm?

comment:6 Changed 9 years ago by mikesherov

Keywords: ie7 ie8 added
Milestone: 1.next1.8
Resolution: duplicate
Status: openclosed

This is actually fixed by #11311, and is now working on edge in the effected browsers.

comment:7 Changed 9 years ago by mikesherov

Duplicate of #11311.

Note: See TracTickets for help on using tickets.